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New Wave
GoldWave supports a wide range of sound attributes.    These attributes must be specified 
when creating a new file.    All new files will be saved in standard RIFF WAVE format.

8 bits vs. 16 bits
16 bits sounds better than 8 bits, but uses twice as much memory.    Also, more sound 
devices support 8 bits than 16 bits.    Therefore, GoldWave selects 8 bits as the default.

Mono vs. Stereo
If you absolutely need stereo sound, select the stereo button.    Stereo sound uses twice as 
much memory as mono sound and can take twice as long to edit.    You can edit individual 
channels by using the Options | Editing dialog.

Sampling Rate
This value determines the quality of the sound.    It is the number of time per second data is 
sent to or received from the sound device.    The drop down list box provides many standard 
rates.    Microsoft recommends that this value should be one of 11025, 22050, or 44100.

11025 Voice and low pitch sounds, relatively small memory usage.
22050 Medium quality music, medium memory usage.
44100 High quality music, potentially CD quality, high memory usage.

The highest quality sound is produced with 16 bit, stereo, 44100Hz.    Note that this uses 
176,400 bytes for every second of sound.    This format should be used if high quality is 
absolutely necessary.

The default rate of 8 bit, mono, 22050Hz uses only 22050 bytes for every second.    This 
format is good if memory and disk space are limited and quality is not very important.

If you plan to do some recording, make sure you specify attributes that are compatible with 
your audio device.

For more information, see GOLDWAVE.WRI Appendix A



Introducing GoldWave

GoldWave is a digital audio editor, player, and recorder.    It can load and edit many different 
sound file formats and display separate graphs for the left and right channels of stereo 
sounds.

Features:
+ Supports RIFF WAVE, VOC, Amiga 8SVX, Sun, NeXT file formats
+ Independent channel editing of stereo sounds
+ A "real-time" oscilloscope when playing
+ Separate "Controls" window for playing and recording
+ Expression evaluator
+ Intelligent editing

GoldWave is a ShareWare program.    This means that you may use this program for a free 30
day trial period.    If you think GoldWave is a useful utility, a registration of $30 Canadian 
(only $25 US) would be appreciated.    You will receive a password that will register your copy
of GoldWave in your name and remove any registration messages.

If you send more than $59 Canadian, you will receive the next version of GoldWave when it 
is available.

To register, fill in the REGISTER.TXT file, then print it out and mail it along with your check or 
money order to the address below:

Chris Craig
P.O. Box 51
St. John's, NF
CANADA    A1C 5H5

My email address is:
chris3@garfield.cs.mun.ca

See GOLDWAVE.WRI for more information.



GoldWave Windows
There are three types of windows used by GoldWave: the Main window, the Scope and 
Controls window, and Sound windows.    The Main window contains a menu bar, a tool bar 
(sometimes called a speed bar or button bar), and an information/status bar at the bottom.   
This window keeps all the sound windows grouped together.    It is similar to the main window
of a word processor, where you can have several document windows open at once.

The Scope and Controls window contains an oscilloscope and sound device controls.    The 
oscilloscope displays the sound as it is being played.    The controls determine the volume, 
left/right balance, and speed at which sounds are played.    A row of standard cassette 
buttons for playing and recording sounds are kept in this window.

Sound windows are created whenever sound files are opened.    Up to 5 sound can be 
opened (provided there is enough memory).    Sound windows display a graph of the sound.   
Mono sounds are shown with a single green graph.    Stereo sounds are shown using a green 
graph for the left channel and a red graph for the right channel.

Below the graph is the "Overview Bar".    It provides useful information about what part of 
the sound is currently selected and what part of the sound is displayed by the graph.    You 
can zoom in on a section of a sound by using the View menu commands.

See Also
File Menu Commands
View Menu Commands



View Menu Commands
View commands allow you to zoom in to and zoom out of the sound graph.    When a sound 
file is initially opened, the graph shows the entire sound.    By selecting a part of the sound 
and using the View Menu Commands, you can get a more detailed graph of the selection.

Zoom Block (Block Button)
Magnifies the selected part of the sound, increasing the detail of the graph.    You can zoom 
in many times (by selecting, then zooming again) until a single sample is shown in the 
graph.    With this level of zoom, you can easily edit individual samples.

Zoom 1:1 (1:1 Button)
Magnifies the sound to give a true representation of the graph of the sound.    The left 
marker is used as the zoom location.    With this command, you can get a detailed graph 
without having to move the right marker.

Unzoom (Out Button)
Shows the entire sound.    Sound windows are initially unzoomed.

See Also
Select part of a sound



Editing Overview
The GoldWave editor is block based.    A block is defined as the highlighted part of the sound 
graph between two vertical markers.    Most editing and effects are performed on this 
highlighted block.    The vertical markers are cyan lines located at the far left side (start 
marker) and far right side (finish marker) of the graph.    They may be difficult to see.

There are two ways to move the markers, depending on Options | Settings setup.    
GoldWave does not use Windows' standard "click-and-drag" method because it does not 
allow accurate positioning of the markers.    The methods below allow you to independently 
set the start and finish markers to the nearest sample (when zoomed in at a 1:1 level or 
better).

Method 1, Quick block select (default):
To move the start marker:

Click the left mouse button on the graph at the point where you want to place the 
start marker.

To move the finish marker:
Click the right mouse button on the graph at the point where you want to place the 
finish marker.

The drawback of this method is that it is easy to accidently change the start/finish marker 
when clicking on a sound window.

Method 2, Grab and drag:
If the "Quick block select" check box in Options | Settings is not checked, then a grab and 
drag method is used.
To move a marker:

1) Position the mouse arrow over the marker.    Make sure the mouse is 
inside the graph area.    You should see the arrow change into a vertical bar 
with small arrows on either side.
2) Press and hold the left mouse button.
3) Move the mouse to the left or right.
4) Release the mouse button when the marker is at the desired position.

The drawback of this method is that the marker must be inside the graph box before you can
move it.    This may not be the case if you are zoomed in.

See Also
Edit individual channels of stereo sounds
Edit Menu Commands
View Menu Commands



File Menu Commands
New
Creates a new sound file and allows you to choose the file's attributes.    New files will always
be saved with Microsoft's RIFF WAVE format.

Open
Opens an existing sound file.    Only 5 files can be opened at one time.    Note that ".au" and 
".snd"" files may take some time to decode.    See GOLDWAVE.WRI for more details.

Save
Saves the current file to the disk.

Save as
Saves the current file to the disk under a different name.    Note: Files are saved in their 
original format.    You must give an appropriate filename extension.

Exit
Exits GoldWave.



Edit Menu Commands
Cut
Copies the block into the clipboard and deletes it from the sound window.

Copy
Copies the block into the clipboard.

Paste
Pastes the clipboard into the sound window.

Mix
Mixes the clipboard with the sound window.

Delete
Deletes the block.

Insert space
Inserts a blank space into the sound window of a size you specify in seconds.    The space is 
inserted at the start marker's position.

Select view (Sel Vw button)
Moves the start and finish markers to the far left and far right of the sound graph.

See Also
Edit individual channels of stereo sounds
Editing Overview



Cut (Cut Button)
Removes the block from the active sound and puts it in the clipboard. The contents of the 
clipboard can then be pasted into a sound window using Paste.
To cut:

1) Move the start and finish markers to the part of the sound you want to 
cut.
2) Choose Cut from the Edit menu or click on the Cut button.

See Also
Delete



Copy (Copy Button)
Copies the block into the clipboard.    The block is not removed.    The contents of the 
clipboard can then be pasted into a sound window using Paste.
To copy:

1) Move the start and finish markers to the part of the sound you want to 
copy.
2) Choose Copy from the Edit menu or click on the Copy button.



Paste (Paste Button)
Places the sound in the clipboard into the active sound.    The sound is inserted at the start 
marker's position.    The length of the active sound is increased so that the clipboard sound 
will fit.    The clipboard sound is automatically converted to match the attributes of the active
sound.
To paste:

1) Move the start marker to the place where you want to paste the 
clipboard sound.
2) Choose Paste from the Edit menu or click on the Paste button.

Tips: By copying a small block and pasting it several times, a stutter effect can be 
achieved.
You can use Paste to convert stereo to mono by copying from a stereo file and pasting
to a mono file.
If a sound format is not supported by your audio device, use File | New to make a 
new compatible sound.    Copy from the original, then Paste to the new.

Technical Note:    Clipboard data is automatically up-sampled or down-sampled to keep pitch 
and playback speed constant.    You can use Effects | Playback rate to change the 
playback speed before copying/cutting.

See Also
Mix



Mix (Mix Button)
This is a special editing feature for sounds.    The sound in the clipboard is blended 
(superimposed) with the active sound.    You are asked for the mix volume.    This volume is 
applied to the clipboard sound as it is being mixed.
To mix:

1) Move the start marker to the place where you want to mix the 
clipboard sound.
2) Choose Mix from the Edit menu or click on the Mix button.

3) Enter the volume to mix the clipboard (100 = normal volume).
4) Choose OK.

Tip: With this feature you could add your own vocals to music.

Technical Note:    Clipboard data is automatically up-sampled or down-sampled to keep pitch 
and playback speed constant.    You can use Effects | Playback rate to change the 
playback speed before copying/cutting.

See Also
Volume
Paste



Delete (Delete Button)
Delete removes the block from the active sound.    The block is not copied to the clipboard.    
Note that if only the left or right channel is active in a stereo sound, then only that channel 
is removed.    Since it is not possible for one channel to be larger than the other, the end of 
the deleted channel is padded with silence (this is also true for Cut).
To delete:

1) Move the start and finish markers to the part of the sound you want to 
delete.
2) Choose Delete from the Edit menu or click on the Delete button.

See Also
Cut



Effects Menu Commands
Echo
Produces an echo in the block.

Fade out
Gradually fades the volume throughout the block.

Invert
Inverts the block.

Maximize volume
Increases the volume of the block.

Playback rate
Changes the rate at which the entire sound is played.

Reverse
Reverses the block so that it will play backwards.

Silence
Silences (mutes) the block.

Volume
Changes the volume of the block.

Expression evaluator
See GOLDWAVE.WRI, Appendix B for details.

See Also
Editing Overview
Edit Menu Commands



Echo
Produces an echo effect with the block.    The echo delay and volume (see Volume) can be 
entered after choosing this command.    You may want to try the default values first.

The longer the delay, the longer it takes for the echo to "bounce" back.    Try values less than
0.1 for a large room, 0.3 for a baseball stadium, above 0.3 for a canyon echo.

The lower the volume, the quieter the echo will be. Values less than 50 give good results.

To make the echo sound correct, GoldWave extends the effect slightly outside the block 
boundary.    This may increase the length of the sound.    If you do not want to modify sound 
outside the block or you do not want the length of the sound to change, use the Options | 
Editing dialog to disable modification outside the block.
To add an echo:

1) Move the start and finish markers to the part of the sound you want to 
add an echo.
2) Choose Echo from the Effects menu.
3) Enter the delay time, then choose OK.
4) Enter the volume, then choose OK.



Fade out
Gradually decreases the volume throughout the block.    The percentage of fade can be 
entered after choosing this command.    The fade percentage is the amount that the volume 
should decrease.    A value of 100 fades to complete silence.    A value of 50 fades to half the 
original volume.
To fade out part of a sound:

1) Move the start and finish markers to the part of the sound you want to 
fade.
2) Choose Fade out from the Effects menu.
3) Enter the fade percentage, then choose OK.

Tip: To fade in a sound, Reverse the block first, Fade out, and Reverse it again.



Invert
Reflects the block data about the x (time) axis.    This produces no noticeable effect in mono 
sounds and has a slight effect in stereo sounds.    Inverting a single channel of a stereo 
sound will produce a surround-sound effect.
To invert part of a sound:

1) Move the start and finish markers to the part of the sound you want to 
invert.
2) Choose Invert from the Effects menu.



Maximize volume
Searches the block for the maximum percent that the volume can be increased without 
producing distortion or clipping errors.    This volume is then applied to the block.    If the 
percentage is above 2000% or equal to 100%, no changes will be made.
To maximize the volume of part of a sound:

1) Move the start and finish markers to the part of the sound you want to 
increase the volume.
2) Choose Maximize Volume from the Effects menu.



Playback rate
Changes the playback rate of the entire sound.    The sound will play faster (or slower) and 
its pitch will be higher (or lower).    Essentially, this just changes the first number in the 
information bar.    Values of 11025, 22050, and 44100 are the recommended values.
To change the playback rate of the entire sound:

1) Choose Playback rate.
2) Enter the new rate, then choose OK.

The Speed control in the Scope and Controls window also affects playback rate.    It only 
changes the device's playback rate, whereas the Playback rate Effect changes the rate 
within the sound.    A Speed of 1.00 is normal.    The new speed will be used the next time a 
sound is played.
To change the playback rate of the audio device:

1) Move the Speed scroll bar to the left or right.    GoldWave will 
automatically find the closest speed that is compatible with your audio device.

Tip:    If you want to convert the actual sampled data from one sampling rate to another, you 
could use Edit | Copy and Edit | Paste.    If the file you Copy from is sampled at 22050Hz 
and the file you paste to is sampled at 11025, then the Paste command will down-sample 
the data as it pastes.    This cuts the size of the sound in half.    Up-sampling is also possible 
this way.



Volume
Modifies the block so that it sounds louder or softer.    The percentage of volume can be 
entered after selecting this command.    Values less than 100 make the sound softer and 
values greater than 100 make the sound louder.    A value of 100 has no effect.    Enter 50 to 
half the volume and 200 to double the volume.
To maximize the volume of part of a sound:

1) Move the start and finish markers to the part of the sound you want to 
change the volume.
2) Choose Volume from the Effects menu.
3) Enter the new volume percentage, then choose OK.

By using independent left/right editing (Options | Editing), the internal balance of a sound 
can be adjusted.

The Volume and Balance controls in the Scope and Controls window also affect volume (if 
your audio device supports them).    They change the device's output volume, whereas the 
Volume Effect actually changes the volume within a sound.
To change the output volume of the audio device:

1) Move the Volume or Balance scroll bar to the left or right.



Options Menu Commands
Input device
Allows you to choose a device for recording sounds.    It also shows you the capabilities of 
your device.

Output device
Allows you to choose a device for playing sounds.    It also shows you the capabilities of your 
device.

Aux volume
Sets the output volume on an auxiliary device.

Settings
Allows you to set certain features in GoldWave.

Editing
Allows you to set sound editing options.



Editing Options
By selecting the menu command Options | Editing, you are presented with a dialog box.

The Channel Editing group lets you control which channel (or channels) will be edited for 
stereo sounds.    For example, if you choose "Left channel", all effects and editing will only 
change or use the left channel.      You can then use Edit | Copy to extract the left channel 
into the clipboard or use Edit | Mix to mix the clipboard with the left channel and so on.

The Modify outside block option prevents certain effects (like Echo) from changing the 
sound outside the block markers.

See Also
Editing Overview



Output device
The list shows you the names of output devices/drivers.    Above the list is a table that tells 
you what sound attributes/formats the driver supports.    All boxes with check marks in them 
are supported by the currently selected driver.    You can select any driver to see its 
capabilities.



Input device
The list shows you the names of input devices/drivers.    Above the list is a table that tells 
you what sound attributes/formats the driver supports.    All boxes with check marks in them 
are supported by the currently selected driver.    You can select any driver to see its 
capabilities.



Aux volume
This dialog allows you to set the output volume on an auxiliary device.    This may be useful 
when recording from a CD-ROM.    A list of installed auxiliary devices is displayed at the 
bottom of the dialog.
To change auxiliary output volume:

1) Select a device.    If the device supports volume control, the "left" 
control will be enabled.    If the device supports stereo volume control, both 
the "left" and "right" controls will be enabled.

2) Adjust the volume with the "left" and/or "right" controls.



Settings
Sound Path is used by File | Open.    You can specify the directory where you keep your 
sound files.    If you type "d:\sound\wave", for example, the File | Open dialog will 
automatically list the files in that directory whenever you start GoldWave.

If Save window positions is checked, the main window and Scope and Controls window 
positions will be saved when you exit GoldWave.    This means you will not have to adjust 
window positions every time you start GoldWave.

If Load uLaw as 8-bits is checked, any encoded file (".au" files) will be converted to 8-bit 
PCM format.    This will cause some loss of quality, but will allow playback on a larger variety 
of audio devices.    If the box is not checked, the data is converted to 16-bit PCM format. If 
your audio device supports 16-bit PCM files, uncheck this box.

The Scope active check box enables or disables the oscilloscope.    Unchecked, the 
oscilloscope is disabled during playback and recording (the oscilloscope box will still be 
present).    Some "synchronous" audio devices do not allow the scope to work.

The Quick block select check box allows you to choose which method to use when 
selecting a block.

See Also
Editing Overview



Playing and Recording Sounds
To play part of a sound:

1) Move the start and finish markers to the part of the sound you want 
play.
2) Choose the play button on the Scope and Controls window (the 
green triangle).

You can pause playback with the pause button (two vertical blue bars).

To record a sound (provided your audio device can record):
1) Move the start and finish markers to the part of the sound you want 
record over (you can use Edit | Insert space to create a place to record the 
sound).
2) Choose the record button the Scope and Controls window (the red 
circle with an 'R').

You can use the stop button (red square) to stop playback or recording at any time.

See Also
Editing Overview for information about setting markers.



Raw File Format
The Raw File Format dialog is presented if any of the following occur:

1) The file has no header information.
2) The file does have a header, but the file structure is incorrect for the 
given header.
3) The file has a new format that GoldWave does not recognize.
4) The file is in a format not supported by GoldWave.

The dialog allows you to specify a format and attributes for the data in the file.    Supported 
data formats are:

WAVE / VOC / PCM:
Unsigned 8-bit data.    Mono or stereo.
Signed 16-bit data.    Mono or stereo.
Default sampling rate: 22050Hz

Amiga / Signed 8-bit
Signed 8-bit or 16-bit data.    Mono or stereo.
Default sampling rate: 16000Hz

AU / SND / micro-Law encoded
Micro-Law coded 8-bit data.    The data is decoded to 8-bit or 16-bit data depending 
on the number of bits you specify.
Default sampling rate: 8000Hz

See GOLDWAVE.WI for a table of supported formats in the Open subsection.

To specify the format and attributes:
1) Select one of the formats specified above.    GoldWave will 
automatically set common attributes for this format.
2) If the default attributes are incorrect, set the correct bits, channels, 
sign, and sampling rate.
3) Choose OK.
4) Play the sample to ensure the attributes are correct.

If the format is incorrect or the attributes are wrong, the sound will play distorted.    You will 
have to close the sound window and reopen it using a different format.
If the sampling rate is incorrect, the sound will play too fast or too slow.    You can use the 
Effect | Playback rate to quickly fix this.

Warning: If you save the file later, any header information will be lost.    You are encouraged 
to save the file under a different name using File | Save as.    Be sure to give a meaningful 
filename extension.



Convert Attributes
By using File | New in conjunction with Edit | Copy and Edit | Mix or Edit | Paste, you can
change the attributes of a sound file.

To convert:
1) Use File | New to create a new sound window with attributes you 
need.
2) Use File | Open to open the sound file to be converted.
3) Choose Edit | Copy to copy the entire file into the clipboard.
4) Active the new sound window by clicking on its title bar.
5) Choose Edit | Mix or Edit | Paste to convert the sound and place the 
result in the new sound window.

Using Edit | Mix with a volume of 100 is similar to using Edit | Paste.    Paste, however, will
insert the converted sound, leaving 5 seconds of blank space at the end of the new sound 
window.

Future versions of GoldWave may support conversions directly.

See Also
Editing Overview
Edit Menu Commands
File Menu Commands




